Subscription payment portal impacting credit card users

Incident Report for Felix

Identified

We have identified the issue with a third party provider and are actively working with them to resolve.

For current customers with reoccurring payments, no further action is required from you at this stage. For new customers or those refreshing their payment details, please utilise direct debit and reach out to your account manager for further information as required.
Posted Apr 22, 2025 - 14:06 AEST

Investigating

We are currently investigating an issue where credit card payments are not processing correctly for Marketplace vendors, impacting their ability to subscribe or renew. Please reach out to your account manager for support in the interim.
Posted Apr 22, 2025 - 12:56 AEST
This incident affects: Web Platform (Vendor Portal).