A probable cause of the reported outage has been identified as an issue from our upstream service provider. We are now monitoring the progress.
Posted Feb 11, 2026 - 08:17 AEST
Update
We are continuing to investigate this issue.
Posted Feb 11, 2026 - 08:12 AEST
Update
We are continuing to investigate this issue.
Posted Feb 11, 2026 - 08:00 AEST
Investigating
Our engineering team is currently investigating reports of an unexpected outage affecting Felix services. Further information will be published as soon as it's available.
Posted Feb 11, 2026 - 07:59 AEST
This incident affected: Web Platform (Contractor Portal, Vendor Portal) and Notifications.