Unexpected Outage
Incident Report for Felix
Resolved
A fix for the issue has been deployed and all Felix services are operational.
Posted May 10, 2021 - 19:26 AEST
Identified
We are currently investigating an issue affecting user access to Felix Services. Further information will be provided shortly.
Posted May 10, 2021 - 19:17 AEST
This incident affected: Web Platform (Contractor Portal).